The managed object model version used to open the persistent store is incompatible with the one that was used to create the persistent store.

I’ve been getting this error today when attempting to build my Sound-Church application. Couldn’t figure it out until I found this post that explained it.

For iOS, look in ~/Library/Application Support/iPhone Simulator/ where version is the iOS version you are targeting to find the offending files. I just blew away all the sub-folders in that folder to solve my problem.

This entry was posted in iOS, XCode and tagged , , . Bookmark the permalink.

Comments are closed.